おはようございます。

おはようございます。WP 4.9 の人柱w、堀田です。 人柱のくせして、修正スキルがない自分が悔しいので、PHPスクールに通いだしました。 それは、さておき、PHPファイルがいじれない件、 11/30のリリースで解消したようです。 あじさいサイトでは、11/30に、他の方のサイトでは、11/18の4.9.1へのアップデートで解消したとの情報をいただいています。 そもそも論、なんでこんなことが起きたか。 ====== 4.9では、WordPress自体を「サンドボックス」という機能で囲むという改善を行いました。 WordPress自体に障害が起きても、サーバー自体には影響ない。という、 そんなセキュリティ上の大規模改修です。 と、いうことで、 WordPress文法的によろしくないのでは?と思われるテーマを使っている方が、テーマ編集画面を開くと、こんな画面がでます。 それでも無理やりテーマを開くと、こんな感じになります。 ※あじさい企画のサイトじゃないです。 また、このエラーを無視して、スタイルシートを無理やり修正した方に、とっても大きな悲劇が発生したという話も入っています。ex. プラグインが全部見えなくなったとかw 大切なお客様相手は、もう少し様子見かなあ。とは思いますが、 WordPress.orgからは、「かなりの大規模セキュリティ対応をしたので、絶対当ててください!」という、連絡が入っています。 コストvs 効果 vs トラブったときの被害などなどみて、注意深く対応する必要がありそうです。。。

【解消したようです】WordPress 4.9 管理画面からPHPファイルがいじれない
おはようございます。WP 4.9 の人柱w、堀田です。 人柱のくせして、修正スキルがない自分が悔しいので、PHPスクールに通いだしました。 それは、さておき、PHPファイルがいじれない件、 11/30のリリースで解消したようで...